summaryrefslogtreecommitdiff
path: root/recipes-lxde/obconf/obconf_2.0.4+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/obconf/obconf_2.0.4+git.bb')
-rw-r--r--recipes-lxde/obconf/obconf_2.0.4+git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-lxde/obconf/obconf_2.0.4+git.bb b/recipes-lxde/obconf/obconf_2.0.4+git.bb
new file mode 100644
index 0000000..954e980
--- /dev/null
+++ b/recipes-lxde/obconf/obconf_2.0.4+git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Tool for configuring the Openbox window manager"
+HOMEPAGE = "http://openbox.org/wiki/ObConf:About"
+SECTION = "x11"
+
+SRCREV = "fa924b595e37f1b13ba4c2e64c367b92bbd3c771"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+DEPENDS = "gtk+ glib-2.0 libglade startup-notification openbox"
+RDEPENDS_{PN} = "openbox"
+
+MIRRORS_prepend () {
+ git://git.openbox.org/dana/obconf git://github.com/danakj/obconf.git
+}
+
+SRC_URI = "git://git.openbox.org/dana/obconf;branch=master;protocol=git \
+ file://obconf-lxde"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}/mime ${datadir}/mimelnk"
+
+inherit autotools-brokensep pkgconfig gettext mime
+
+do_configure_prepend () {
+ autopoint --force || bbfatal "autopoint failed"
+}
+
+do_configure_append () {
+ sed -i -e "/^Exec/s:obconf.*$:obconf-lxde:" ${S}/obconf.desktop || bbfatal "sed failed"
+}
+
+do_install_append () {
+ install -m 0755 ${WORKDIR}/obconf-lxde ${D}${bindir}/
+}