summaryrefslogtreecommitdiff
path: root/recipes-lxde/lxappearance/lxappearance_0.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-lxde/lxappearance/lxappearance_0.6.2.bb')
-rw-r--r--recipes-lxde/lxappearance/lxappearance_0.6.2.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/recipes-lxde/lxappearance/lxappearance_0.6.2.bb b/recipes-lxde/lxappearance/lxappearance_0.6.2.bb
index 1688574..bea70cd 100644
--- a/recipes-lxde/lxappearance/lxappearance_0.6.2.bb
+++ b/recipes-lxde/lxappearance/lxappearance_0.6.2.bb
@@ -5,12 +5,20 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "gtk+ intltool-native"
+DEPENDS = "intltool-native"
SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.xz"
SRC_URI[md5sum] = "21ee79c7686a80efddaa1b7928f51e21"
SRC_URI[sha256sum] = "4462136e01f991d4c546f23a8cf59a4092f88ecdff587597959f8062e2ea201f"
+PACKAGECONFIG ?= "gtk3"
+PACKAGECONFIG[gtk3] = "--enable-gtk3,,gtk+3"
+python __anonymous () {
+ depends = d.getVar("DEPENDS", d, 1)
+ if 'gtk3' not in d.getVar('PACKAGECONFIG', True):
+ d.setVar("DEPENDS", "%s gtk+" % depends)
+}
+
inherit autotools gettext pkgconfig
fakeroot do_fixup_ownership () {