summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2012-10-04 13:28:14 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2013-10-15 13:41:39 +0200
commitd88c2e3f5e1d1465164f494e9d10f3d4451cc9aa (patch)
treead6ca42c85a6231063c12ee544d8a684957cedd4
parent14da827722513a736685ce16985e47bffc932616 (diff)
Add missing autoconf tests required by newer autoconf version Backported a bugfix to lxdm (lxdm used 100% CPU)
-rw-r--r--recipes-lxde/lxappearance/lxappearance-0.5.1/lxappearance_missing_am_prog_cc_c_o.patch10
-rw-r--r--recipes-lxde/lxappearance/lxappearance_0.5.1.bb6
-rw-r--r--recipes-lxde/lxdm/lxdm-0.4.1/fix_event_check_bug_caused_cpu_100.patch25
-rw-r--r--recipes-lxde/lxdm/lxdm-0.4.1/missingAM_GLIB_GNU_GETTEXT.patch25
-rw-r--r--recipes-lxde/lxdm/lxdm_0.4.1.bb7
-rw-r--r--recipes-lxde/lxpanel/lxpanel-0.5.8/lxpanel_missing_am_prog_ar.patch10
-rw-r--r--recipes-lxde/lxpanel/lxpanel_0.5.8.bb6
-rw-r--r--recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_missing_am_prog_cc_c_0.patch10
-rw-r--r--recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_remove_gnu_make_extension.patch11
-rw-r--r--recipes-lxde/lxpolkit/lxpolkit_0.1.0.bb6
10 files changed, 110 insertions, 6 deletions
diff --git a/recipes-lxde/lxappearance/lxappearance-0.5.1/lxappearance_missing_am_prog_cc_c_o.patch b/recipes-lxde/lxappearance/lxappearance-0.5.1/lxappearance_missing_am_prog_cc_c_o.patch
new file mode 100644
index 0000000..6d76a18
--- /dev/null
+++ b/recipes-lxde/lxappearance/lxappearance-0.5.1/lxappearance_missing_am_prog_cc_c_o.patch
@@ -0,0 +1,10 @@
+--- lxappearance-0.5.1/configure.ac~ 2011-07-29 16:50:18.000000000 +0200
++++ lxappearance-0.5.1/configure.ac 2012-08-12 16:52:52.000000000 +0200
+@@ -16,6 +16,7 @@
+
+ # Checks for programs.
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ # AM_PROG_LIBTOOL
+
+ # Checks for libraries.
diff --git a/recipes-lxde/lxappearance/lxappearance_0.5.1.bb b/recipes-lxde/lxappearance/lxappearance_0.5.1.bb
index 5092cfe..1d03a6c 100644
--- a/recipes-lxde/lxappearance/lxappearance_0.5.1.bb
+++ b/recipes-lxde/lxappearance/lxappearance_0.5.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "LXDE GTK+ theme switcher"
HOMEPAGE = "http://lxde.org/"
SECTION = "x11"
-PR = "r1"
+PR = "r2"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
@@ -10,7 +10,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "gtk+"
SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.gz \
- file://empty-cursor.patch"
+ file://empty-cursor.patch \
+ file://lxappearance_missing_am_prog_cc_c_o.patch \
+"
SRC_URI[md5sum] = "34d157a7fe97ef0b93db8fab3f251e07"
SRC_URI[sha256sum] = "74e638257092201a572f1fcd4eb93c195c9fa75e27602662de542b002e6deade"
diff --git a/recipes-lxde/lxdm/lxdm-0.4.1/fix_event_check_bug_caused_cpu_100.patch b/recipes-lxde/lxdm/lxdm-0.4.1/fix_event_check_bug_caused_cpu_100.patch
new file mode 100644
index 0000000..f0ca23b
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm-0.4.1/fix_event_check_bug_caused_cpu_100.patch
@@ -0,0 +1,25 @@
+From d4e41ecb36a1ea29482b75674d804bb0f05540b2 Mon Sep 17 00:00:00 2001
+From: dgod <dgod.osa@gmail.com>
+Date: Sun, 25 Dec 2011 15:23:19 +0800
+Subject: [PATCH] fix event check bug caused cpu 100%
+
+---
+ src/lxcom.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/lxcom.c b/src/lxcom.c
+index 02763eb..18ee12e 100644
+--- a/src/lxcom.c
++++ b/src/lxcom.c
+@@ -89,7 +89,7 @@ static gboolean lxcom_prepare (GSource *source,gint *timeout)
+
+ static gboolean lxcom_check(GSource *source)
+ {
+- return TRUE;
++ return (((LXComSource*)source)->poll.revents&G_IO_IN)?TRUE:FALSE;
+ }
+
+ static gboolean lxcom_dispatch (GSource *source,GSourceFunc callback,gpointer user_data)
+--
+1.7.4.1
+
diff --git a/recipes-lxde/lxdm/lxdm-0.4.1/missingAM_GLIB_GNU_GETTEXT.patch b/recipes-lxde/lxdm/lxdm-0.4.1/missingAM_GLIB_GNU_GETTEXT.patch
new file mode 100644
index 0000000..43a8b1c
--- /dev/null
+++ b/recipes-lxde/lxdm/lxdm-0.4.1/missingAM_GLIB_GNU_GETTEXT.patch
@@ -0,0 +1,25 @@
+diff -urNdb lxdm-0.4.1.old//config.h.in lxdm-0.4.1//config.h.in
+--- lxdm-0.4.1.old//config.h.in 2011-07-29 15:43:45.000000000 +0200
++++ lxdm-0.4.1//config.h.in 2011-11-29 22:26:14.000000000 +0100
+@@ -1,5 +1,8 @@
+ /* config.h.in. Generated from configure.ac by autoheader. */
+
++/* always defined to indicate that i18n is enabled */
++/*#undef ENABLE_NLS*/
++
+ /* Gettext package. */
+ #undef GETTEXT_PACKAGE
+
+diff -urNdb lxdm-0.4.1.old//configure.ac lxdm-0.4.1//configure.ac
+--- lxdm-0.4.1.old//configure.ac 2011-07-29 15:42:33.000000000 +0200
++++ lxdm-0.4.1//configure.ac 2011-11-29 22:23:08.000000000 +0100
+@@ -141,6 +141,9 @@
+ GETTEXT_PACKAGE=lxdm
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Gettext package.])
++AM_GLIB_GNU_GETTEXT
++
++#AC_SUBST(GMSGFMT, ($MSGFMT))
+
+ AC_CONFIG_FILES([
+ Makefile
diff --git a/recipes-lxde/lxdm/lxdm_0.4.1.bb b/recipes-lxde/lxdm/lxdm_0.4.1.bb
index cb43f23..53e1104 100644
--- a/recipes-lxde/lxdm/lxdm_0.4.1.bb
+++ b/recipes-lxde/lxdm/lxdm_0.4.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "LXDE Display Manager"
HOMEPAGE = "http://lxde.org/"
SECTION = "x11"
-PR = "r2"
+PR = "r3"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
@@ -19,7 +19,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${PN}-${PV}.tar.gz \
file://${P}-oe-xsession.patch \
file://${P}-uclibc-friendly.patch \
file://xinitrc \
- file://init"
+ file://init \
+ file://missingAM_GLIB_GNU_GETTEXT.patch \
+ file://fix_event_check_bug_caused_cpu_100.patch \
+"
SRC_URI[md5sum] = "8da1cfc2be6dc9217c85a7cf51e1e821"
SRC_URI[sha256sum] = "9e0d0a5672fcf31a18de8178ce73eab1723d6ae7097dfe41e9fe2c46e180cf08"
diff --git a/recipes-lxde/lxpanel/lxpanel-0.5.8/lxpanel_missing_am_prog_ar.patch b/recipes-lxde/lxpanel/lxpanel-0.5.8/lxpanel_missing_am_prog_ar.patch
new file mode 100644
index 0000000..0a360a8
--- /dev/null
+++ b/recipes-lxde/lxpanel/lxpanel-0.5.8/lxpanel_missing_am_prog_ar.patch
@@ -0,0 +1,10 @@
+--- lxpanel-0.5.8/configure.ac~ 2011-07-29 14:37:01.000000000 +0200
++++ lxpanel-0.5.8/configure.ac 2012-08-12 16:48:31.000000000 +0200
+@@ -16,6 +16,7 @@
+ AC_PROG_LN_S
+ AC_PROG_INTLTOOL(, [no-xml])
+ AM_PROG_CC_C_O
++AM_PROG_AR
+
+ #Initialize libtool
+ LT_PREREQ([2.2])
diff --git a/recipes-lxde/lxpanel/lxpanel_0.5.8.bb b/recipes-lxde/lxpanel/lxpanel_0.5.8.bb
index 75c89a5..68829fb 100644
--- a/recipes-lxde/lxpanel/lxpanel_0.5.8.bb
+++ b/recipes-lxde/lxpanel/lxpanel_0.5.8.bb
@@ -2,6 +2,8 @@ DESCRIPTION = "LXDE Panel"
HOMEPAGE = "http://lxde.org/"
SECTION = "x11"
+PR = "r2"
+
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=9d19a9495cc76dc96b703fb4aa157183"
@@ -9,7 +11,9 @@ RDEPENDS = "gtk+ menu-cache lxmenu-data libxmu libxpm alsa-lib"
DEPENDS = "${RDEPENDS}"
SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${PN}-${PV}.tar.gz \
- file://lxpanel-0.5.6-broken-apps.patch"
+ file://lxpanel-0.5.6-broken-apps.patch \
+ file://lxpanel_missing_am_prog_ar.patch \
+"
SRC_URI[md5sum] = "129fae75d1cd3983fd94542c573a70a1"
SRC_URI[sha256sum] = "6a3579d6f384c03a33a03e4d32016428c84eb0f2bc421704f724fe2cc015cddd"
diff --git a/recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_missing_am_prog_cc_c_0.patch b/recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_missing_am_prog_cc_c_0.patch
new file mode 100644
index 0000000..5fa39e6
--- /dev/null
+++ b/recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_missing_am_prog_cc_c_0.patch
@@ -0,0 +1,10 @@
+--- lxpolkit-0.1.0/configure.ac~ 2011-07-24 13:59:15.000000000 +0200
++++ lxpolkit-0.1.0/configure.ac 2012-08-12 17:06:47.000000000 +0200
+@@ -11,6 +11,7 @@
+
+ # Checks for programs.
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ # AM_PROG_LIBTOOL
+
+ # Checks for libraries.
diff --git a/recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_remove_gnu_make_extension.patch b/recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_remove_gnu_make_extension.patch
new file mode 100644
index 0000000..c719828
--- /dev/null
+++ b/recipes-lxde/lxpolkit/lxpolkit-0.1.0/lxpolkit_remove_gnu_make_extension.patch
@@ -0,0 +1,11 @@
+--- lxpolkit-0.1.0/data/ui/Makefile.am~ 2011-07-24 13:59:15.000000000 +0200
++++ lxpolkit-0.1.0/data/ui/Makefile.am 2012-08-12 17:09:53.000000000 +0200
+@@ -12,7 +12,7 @@
+ $(NULL)
+
+ # Purge GtkBuilder UI files
+-%.ui: %.glade
++.ui: .glade
+ cp $< $@
+ $(top_srcdir)/src/xml-purge $@
+
diff --git a/recipes-lxde/lxpolkit/lxpolkit_0.1.0.bb b/recipes-lxde/lxpolkit/lxpolkit_0.1.0.bb
index de0e25b..2617274 100644
--- a/recipes-lxde/lxpolkit/lxpolkit_0.1.0.bb
+++ b/recipes-lxde/lxpolkit/lxpolkit_0.1.0.bb
@@ -2,12 +2,16 @@ DESCRIPTION = "Simple PolicyKit authentication agent"
HOMEPAGE = "http://lxde.org/"
SECTION = "x11"
+PR = "r2"
+
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
DEPENDS = "glib-2.0 gtk+ polkit"
-SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.gz"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${P}.tar.gz \
+ file://lxpolkit_missing_am_prog_cc_c_0.patch \
+ file://lxpolkit_remove_gnu_make_extension.patch"
SRC_URI[md5sum] = "2597b00035fe1d695219e0f9bfa8c26f"
SRC_URI[sha256sum] = "511affca8f55adc67031fb3627b9889064c685e4b983737d8deecdf4f94f008b"