summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Tworek <tworaz666@gmail.com>2011-11-06 22:27:56 +0100
committerPeter Tworek <tworaz666@gmail.com>2011-11-06 22:27:56 +0100
commit96ebb4241125e0dcda01a43a31c2c93f1089674f (patch)
tree07e069b0ea482ab2ddc96ff5399ab0e9001ee67b
New layer: meta-lxde. Most stuff is imported from classic oe.
-rw-r--r--conf/layer.conf9
-rw-r--r--recipes-graphics/imlib2/imlib2_1.4.4.bb58
-rw-r--r--recipes-lxde/lxterminal/lxterminal_0.1.11.bb15
-rw-r--r--recipes-lxde/openbox/openbox_3.5.0.bb59
4 files changed, 141 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..ac5002e
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,9 @@
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "lxde-layer"
+BBFILE_PATTERN_lxde-layer := "^${LAYERDIR}/"
+BBFILE_PRIORITY_lxde-layer = "7"
diff --git a/recipes-graphics/imlib2/imlib2_1.4.4.bb b/recipes-graphics/imlib2/imlib2_1.4.4.bb
new file mode 100644
index 0000000..22550ae
--- /dev/null
+++ b/recipes-graphics/imlib2/imlib2_1.4.4.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "A graphic library for file loading, saving, rendering, and manipulation."
+LICENSE = "MIT | BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=344895f253c32f38e182dcaf30fe8a35"
+DEPENDS = "freetype libpng jpeg giflib tiff zlib bzip2 virtual/libx11 libxext libid3tag"
+PROVIDES = "virtual/imlib2"
+
+PV = "1.4.4"
+PR = "r0"
+
+SRC_URI="http://downloads.sourceforge.net/project/enlightenment/imlib2-src/${PV}/imlib2-${PV}.tar.gz"
+SRC_URI[md5sum] = "9e7589e90519bc6ac2f4656ea6869439"
+SRC_URI[sha256sum] = "a4de52c90b8cd155b41ca70c2d34209f7b94a9e4f8e77582f2682a1795306198"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --with-x \
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-jpeg \
+ --with-pmg \
+ --with-tiff \
+ --with-gif \
+ --with-zlib \
+ --with-bzip2 \
+ --with-id3 \
+ "
+
+# TODO: Use more fine granular version
+#OE_LT_RPATH_ALLOW=":${libdir}/imlib2/loaders:${libdir}/imlib2/filters:"
+#OE_LT_RPATH_ALLOW = "any"
+#OE_LT_RPATH_ALLOW[export]="1"
+
+do_install_append() {
+ install -m 0755 imlib2-config ${STAGING_BINDIR_CROSS}
+}
+
+PACKAGES =+ "\
+ ${PN}-loaders-dbg \
+ ${PN}-filters-dbg \
+ ${PN}-loaders-dev \
+ ${PN}-filters-dev \
+ ${PN}-tools-dbg \
+ ${PN}-loaders \
+ ${PN}-filters \
+ ${PN}-tools"
+
+FILES_${PN} = "${libdir}/lib*.so.* ${libdir}/imlib2/*/*.so"
+FILES_${PN}-dbg = "${libdir}/.debug/ ${bindir}/.debug/ ${prefix}/src/debug/"
+FILES_${PN}-dev += "${bindir}/imlib2-config ${libdir}/*.so ${includedir}"
+FILES_${PN}-tools = "${bindir} ${datadir}/${PN}"
+FILES_${PN}-loaders = "${libdir}/imlib2/loaders/*.so"
+FILES_${PN}-filters = "${libdir}/imlib2/filters/*.so"
+FILES_${PN}-tools-dbg += "${bindir}/.debug"
+FILES_${PN}-loaders-dbg += "${libdir}/imlib2/loaders/.debug"
+FILES_${PN}-filters-dbg += "${libdir}/imlib2/filters/.debug"
+FILES_${PN}-loaders-dev += "${libdir}/imlib2/loaders/*.la"
+FILES_${PN}-filters-dev += "${libdir}/imlib2/filters/*.la"
diff --git a/recipes-lxde/lxterminal/lxterminal_0.1.11.bb b/recipes-lxde/lxterminal/lxterminal_0.1.11.bb
new file mode 100644
index 0000000..a23d4ba
--- /dev/null
+++ b/recipes-lxde/lxterminal/lxterminal_0.1.11.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Lightweight vte-based tabbed terminal emulator for LXDE"
+HOMEPAGE = "http://lxde.sf.net"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+RDEPENDS = "gtk+ vte glib-2.0"
+DEPENDS = "${RDEPENDS} pkgconfig-native gettext intltool"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lxde/${PN}-${PV}.tar.gz"
+SRC_URI[md5sum] = "fd9140b45c0f28d021253c4aeb8c4aea"
+SRC_URI[sha256sum] = "f495166b308a96e8c30c8892b33ab163f3865253a9bbd4bdac462f974fda7253"
+
+inherit autotools
+
diff --git a/recipes-lxde/openbox/openbox_3.5.0.bb b/recipes-lxde/openbox/openbox_3.5.0.bb
new file mode 100644
index 0000000..b02f4db
--- /dev/null
+++ b/recipes-lxde/openbox/openbox_3.5.0.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "A standards compliant, fast, light-weight, extensible window manager"
+HOMEPAGE = "http://openbox.org"
+SECTION = "x11/wm"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+PV = "3.5.0"
+PR = "r2"
+
+RDEPENDS = "glib-2.0 libxml2 pango imlib2 startup-notification libxft libxrandr libxt"
+DEPENDS = "${RDEPENDS} pkgconfig-native xextproto xf86vidmodeproto gtk-engines"
+RDEPENDS_${PN} = "openbox-theme-clearlooks"
+
+SRC_URI = "http://openbox.org/dist/openbox/openbox-${PV}.tar.gz"
+SRC_URI[md5sum] = "00441b53cf14c03566c8e82643544ff9"
+SRC_URI[sha256sum] = "6fa90016530b3aa6102e254079461977439398531fb23e7ec076ff2c140fea0a"
+
+inherit autotools update-alternatives gettext
+
+EXTRA_OECONF += "\
+ --enable-session-management \
+ --disable-xinerama \
+ --with-x\
+ "
+
+ALTERNATIVE_PATH = "${bindir}/openbox"
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "10"
+
+PACKAGES =+ "${PN}-gnome ${PN}-gnome-dbg ${PN}-kde ${PN}-kde-dbg"
+FILES_${PN} += "${datadir}/gnome ${datadir}/xsessions"
+FILES_${PN}-gnome = "\
+ ${bindir}/${PN}-gnome-session \
+ ${bindir}/gnome-panel-control \
+ ${bindir}/gdm-control \
+ ${datadir}/xsessions/${PN}-gnome.desktop \
+ ${datadir}/gnome \
+ "
+FILES_${PN}-gnome-dbg = "\
+ ${bindir}/.debug/${PN}-gnome-session \
+ ${bindir}/.debug/gnome-panel-control \
+ ${bindir}/.debug/gdm-control \
+ "
+FILES_${PN}-kde = "\
+ ${bindir}/${PN}-kde-session \
+ ${datadir}/xsessions/${PN}-kde.desktop \
+ "
+FILES_${PN}-kde-dbg = "\
+ ${bindir}/.debug/${PN}-kde-session \
+ "
+
+PACKAGES_DYNAMIC += "${PN}-theme-*"
+
+python populate_packages_prepend() {
+ theme_dir = bb.data.expand('${datadir}/themes/', d)
+ theme_name = bb.data.expand('${PN}-theme-%s', d)
+ do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
+}