summaryrefslogtreecommitdiff
path: root/freertos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'freertos/CMakeLists.txt')
-rw-r--r--freertos/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/freertos/CMakeLists.txt b/freertos/CMakeLists.txt
index 23eb791..bb81dd9 100644
--- a/freertos/CMakeLists.txt
+++ b/freertos/CMakeLists.txt
@@ -5,11 +5,10 @@ list(APPEND SOURCES
${CMAKE_CURRENT_LIST_DIR}/src/event_groups.c
${CMAKE_CURRENT_LIST_DIR}/src/list.c
${CMAKE_CURRENT_LIST_DIR}/src/queue.c
+ ${CMAKE_CURRENT_LIST_DIR}/src/stream_buffer.c
${CMAKE_CURRENT_LIST_DIR}/src/tasks.c
${CMAKE_CURRENT_LIST_DIR}/src/timers.c
${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/port.c
- ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/fsl_tickless_systick.c
- ${CMAKE_CURRENT_LIST_DIR}/src/portable/GCC/${PROCESSOR_FAMILY}/fsl_tickless_lptmr.c
# include the specified heap allocator
${CMAKE_CURRENT_LIST_DIR}/src/portable/MemMang/heap_${FREERTOS_HEAP_ALLOCATOR}.c
)